Browse topics, discover Works With Legrand community!

Bug Report F454 Fw:2.0.51

I don't know if this is the right place, but I want to report a bug on the latest available firmware for F454 gateway.

The bug is on the web server side.

How to reproduce
Put the F454 behind a router and set up a port forwarding rule on the router with a public port different than 443.


Let's say that your IPs are as follows:

F454 LAN IP =

You set up a port forwarding rule like this:

Public Port = 8000
Private Port = 443
IP Address =

So when you are outside your local network you can point your browser at and your router will redirect you to the F454 web page on port 443, will get a connectivity error.

...check device connectivity...

Here is explained the bug:
The F454 webapp works by calling an internal API to get and set datas from/to the gateway.
This API endpoint sits at


The webapp retrieves the API endpoint from a config.js file sitting at


At line 23 of config.js there's this code:

api_url : "https://"+document.domain+"/myhomeapi",

So, now you should understand where the bug sits:
document.domain only gets the hostname, but doesn't consider the port.

So the webapp looks for the API endpoint at, but it should be looking at instead.

The fix is very easy: the only thing to do would be to replace line 23 of config.js with:

api_url : "https://""/myhomeapi",

Unfortunately, this is something we cannot do as end users/installers and it's not even a setting we can change with MyHome Suite.

I understand that this is an old product and the firmware has been updated in 2017 last time, but I believe it's a quite common gateway and it has a big user base.

This bug may not represent an issue for users with just 1 gateway installed, as they could simply set up 443 as the public port too, but it can be a big issue for multi-apartment installations working on the same LAN and exposed through a single router.

P.S. In addition to above, I believe that the camera image feature should be broken too, because at line 10 of the same config.js file there is this:

camera_image_url: "https://"+document.domain+'/JPEGgrab.cgi'


Thanks for your feedback. I send it to our developer's team

Have a good day,

Leslie - Community Manager

Thank you Leslie.

Would it be possible for you to share with us the root password, so that we can fix this by ourselves while we wait for the official fix to be released?

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.


message2 replies
people2 participants