Forum

Browse topics, discover Works With Legrand community!

Home + Control user plant empty

Hi all,

when trying to get my plant id I got

200 Ok, but {"plants": []}

how can I get it? In my home+ app my legrand application is authorized only for netatmo...why???

BR,

Michele

Hi Michele,

Can you please check in your Home + Control application "Account" section in the menu. Is the email address of your installation the same than the one you use to authenticate in your /authorization request ?

You must use the credentials of your Home + Control application to access your plants. Otherwise, you will retrieve a 200 OK response but with an empty plant

Have a good day,

Leslie - Community Manager

Hi Leslie,

I was connected with my application Eedomus and all was good.

Since I have added physicaly 4 plugs (now I get 59 components) when I test a component I got this message :

{ "statusCode": 403, "message": "Out of call volume quota. Quota will be replenished in 09:54:22." }

Could you help me and explain me the signification of this message.

Have a good day,

Roland

Hello Roland,

There is a limit at 500 calls per day and per end-user for the API. As you have an important amount of devices, I suppose you reached the threshold with your GET requests via Eedomus. You have to wait for the quota to be renewed, or to use an other end-user account

Meanwhile, your installation is still able to be used via your Home + Control application

Have a good day,

Leslie - Community Manager

Hi Leslie,

thank you for the quick reply. I have checked the account email and it's the same used for Home+. what should I do?

br,

Michele

Michele,

Can you please do the following :

In Home + Control application go in Menu > My account > Third-party applications. You should see the name or the ID of your Works with Legrand application
If you don't see it, copy/paste this URL in your web browser : https://partners-login.eliotbylegrand.com/authorize?response_type=code&redirect_uri=YOUR_URI&client_id=YOUR_ID.

Where redirect_uri is the one defined in your application on Works with Legrand, and client_id your application_id

Then, you will be asked to authenticate with your Home + Control credentials and to accept scopes. Verify in "Third-party applications" on Home + Control if you now see your application

You can finally retry to make your GET request for plants

If you still have an empty plant, please send me your email address and application ID via the contact form. I'll then check in database if I see your devices

Have a good day,

Leslie - Community Manager

Hi Leslie,

your suggestion procedure done. I was redirected to a page to grant access to bticino but the "accept" button is doing anything.

"bticino"

I will contact you in the form.

BR,

Michele

Hello Michele,

I did some tests with one of our developers. It seems like your Legrand account is not well linked

Can you please go in your Home + Control application :

- Menu > My account > Third-party applications

- At the bottom click on the link "I can't install a partner application"

- Follow the steps

Can you please tell me if it resolved your issue ?

Thanks and have a good day,

Leslie - Community Manager

Hi Leslie,

done and solved thank you!

BR,

Michele

Great to read that ! Don't hesitate if you have any other question

Have a good day,

Leslie - Community Manager

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Information

watch_later 11 months ago
message9 replies
people3 participants