Forum

Browse topics, discover Works With Legrand community!

Home+Control API - respond "Email already exists"

Hello Leslie

I tried to get user's plant by APIs list, all text box parameter were filled but I received error:

{
"errors": [{
"userMessage": "",
"internalMessage": "Email already exists",
"code": 8
}]
}

Please give me some advices on this issue

Thank you

Tuan Le

  • This topic was modified 1 month, 2 weeks ago by Tuan.
  • This topic was modified 1 month, 2 weeks ago by Tuan.

Hi Tuan,

It looks like an issue when your Netatmo end-user account is not correctly linked to your WWL developer account

Could you please try to go to your Home + Control application (while connected to your end-user account) and in the menu : My account > Third-party applications > at the bottom you have a link "I can't use a third-party application". Click on it, follow the steps and please tell me if it resolves your linking issue

Have a good day,

Leslie - Community Manager

Hi Leslie

I logged in to user-account -> My account > ...> Third-party applications > click on "I can't use a third-party application". It asked me to create account, then press on "create account, it took me Home+Control logging page.  I inputed username and password of Developer account and it showed error as attached image.

Thanks for help

Tuan Le

  • This reply was modified 1 month, 2 weeks ago by Tuan.
Images:
You must be logged in to view attached files.

Hello Tuan,

The account to use is the end-user (the one you use to access your devices on Home + Control application)

If it still doesn't work, please send me via the contact form the email address you use for your end-user account and I'll check in the database if I see something strange

Have a good day,

Leslie - Community Manager

Hi Leslie,
I try to input the end-user account but it is still error. I send a contact form to you. Please help to check
Thank you
Tuan le

I write you here as I can't send you an email on your tuan@... mailbox (unauthorized sender email)

According to what I have in database the email autom...@....com is not correctly converted into a Legrand - Netatmo - Bticino account 
By curiosity I tested tuan@... email address and this one seems OK 
 
Could you please retry to do the process in "Third-party application" while being connected in Home + Control app with autom...@...com email address ? Then, please tell me if you still have this error page : https://static.developer.legrand.com/files/2021/12/errorNetatno.jpg
 
If yes it's maybe an issue on Netatmo's side, I'll see with them
 
Have a good day,
Leslie - Community Manager

Hi Leslie,
Sorry about my email tuan@. I have some problem with that email, but that email is working , It just reject some domain but I don't know the reason. We could keep contacting on forum, for me it is ok.
I login again by account autom...@...com ( end user account of Home+control with connected devices). Again it takes me to error.
Just FYI, account tuan@.... is my Legrand developer account which does not connect to any Connected device, but I used to login Home+Control without gateway, sometimes.
Thanks for help
Tuan Le

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

Information

message6 replies
people2 participants