Forum

Browse topics, discover Works With Legrand community!

HomeKit No Response when using Dimmer

Hi,
I have recently installed a house full of Legrand Arteor and HPM Excel Life with Netatmo dimmable switches.

The switches themselves turn on and off perfectly fine in the Home+Control App and with HomeKit. However when I use HomeKit to adjust the brightness of any of the light switches, the Home App will show a “No Response” for that particular switch. What is strange is that the light actually dims as requested by my HomeKit command, but it looks like the acknowledgement from the Legrand hub is either not getting back to my HomeKit hub (Apple TV or HomePod) or is timing out before it receives the successful acknowledgement. And because I get this “No Response” message, I cannot then execute any further commands to that switch via HomeKit unless I wait a while for it to reset on its own or force togging on/off commands repeatedly in HomeKit. As mentioned, no issues in the Home+Control app nor with the physical switch. I also don’t have any HomeKit issues with simple on/off commands on the same dimmable switches. So it seems to be completely related to the dimming commands.

Any ideas what’s causing the issue? It’s quite frustrating as the dimming function is the more expensive option which I can’t use or I lose access to using the switch reliably.

  • This topic was modified 2 months, 3 weeks ago by PJ.
  • This topic was modified 2 months, 3 weeks ago by PJ. Reason: Formatting

Hi,

I am experiencing the same issue with Legrand Vallena Allure with Netatmo. It is very annoying and has been going for months. All the rest of my HomeKit devices are working perfectly except Legrand. I've tried multiple different setups for my router and setting up HomeKit from scratch but nothing helps. There is no fix yet that I know of. I really hope somebody at Legrand takes this seriously and fixes it soon.

Regards,

Petar

Hello,

I received similar messages for HomeKit as vocal commands for dimming are working but responding with a message like "Sorry, it doesn't work". Also, the states changes are not displayed in HomeKit app. I suppose that the issue comes from the fact the gateway correctly receives the command, but it's not correctly interpreted in HomeKit

I reported it to the teams in order to investigate. I'll warn you once I know more

Have a good day,

Leslie - Community Manager

Hi Leslie and team,

Have you resolved the issue yet? Do you have an update?

It’s been nearly 2 months and it still doesn’t work.

Thanks,

PJ

Hi PJ,

It's still in investigation. We managed to reproduce the behavior under some circumstances and try to understand the root cause in order to fix it correctly

Have a good day,

Leslie - Community Manager

Hello PJ,

Good news : the issue is found and will be fixed in the next release of the gateway firmware (v.206)

It should arrive end of October / beginning of November

Have a good day,

Leslie - Community Manager

Hi Leslie,

That is great news, thanks for updating us. Will that firmware be made available worldwide (like Australia)?

I seem to be on firmware “153” currently (which I thought is the latest, but I don’t know). Can I confirm that the “Gateway Power Outlet” model will also get access to v.206?

 

Thanks,

PJ

PJ,

It will be worldwide, including Australia. v153 is the latest version of the gateway, you are up to date 😉

Your "Gateway Power Outlet" is indeed the module that will benefit from the v206 firmware

Have a good day,

Leslie - Community Manager

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

Information

message7 replies
people3 participants