Forum

Browse topics, discover Works With Legrand community!

HomeKit No Response when using Dimmer

Hi,
I have recently installed a house full of Legrand Arteor and HPM Excel Life with Netatmo dimmable switches.

The switches themselves turn on and off perfectly fine in the Home+Control App and with HomeKit. However when I use HomeKit to adjust the brightness of any of the light switches, the Home App will show a “No Response” for that particular switch. What is strange is that the light actually dims as requested by my HomeKit command, but it looks like the acknowledgement from the Legrand hub is either not getting back to my HomeKit hub (Apple TV or HomePod) or is timing out before it receives the successful acknowledgement. And because I get this “No Response” message, I cannot then execute any further commands to that switch via HomeKit unless I wait a while for it to reset on its own or force togging on/off commands repeatedly in HomeKit. As mentioned, no issues in the Home+Control app nor with the physical switch. I also don’t have any HomeKit issues with simple on/off commands on the same dimmable switches. So it seems to be completely related to the dimming commands.

Any ideas what’s causing the issue? It’s quite frustrating as the dimming function is the more expensive option which I can’t use or I lose access to using the switch reliably.

  • This topic was modified 1 year, 2 months ago by PJ.
  • This topic was modified 1 year, 2 months ago by PJ. Reason: Formatting

Hi Dawid,

According to the expected release plan, 100% of installations should be updated to v209 now. As it's "expected", it could maybe take a little bit more time

If you are still on v153 on Monday, please send me an email via the contact form and give me the Mac Address of your Gateway for investigation

Have a good day,

Leslie - Community Manager

I still have the v153 firmware too. No updates yet.

Hello Petrov,

As I said to Dawid, please wait until Monday and write me via the contact form with your Mac Address if it's still not updated

Have a good day,

Leslie - Community Manager

Thanks for response!

I'll wait until  Monday and if it's still not updated then send MAC address via contact form.

Have a nice weekend

DW

Hi Leslie, it’s Monday and I’m still on v153. Not sure where the MAC address is but I see a serial number in the app. It is 00:04:74:25:28:e4. Is this all you need to push the update?

 

thanks

simon

Hi, same here. Seems like none of us got any updates. 🙂

Hi Leslie,

my gateway has been upgraded and all dimmers works flawlessly with Homekit 🙂 Thx!

One extra question: is there any release note about this upgrade? Is it only fixing some bugs or new functionalities/improvements have been also added?

Have a good day!

DW

Hello,

I just discussed with developers about the OTA : it unfortunately took a little delay. For the moment about 70% of installations are updated. The good news is that no problems occurred during these updates. I don't have for the moment a precise date to achieve 100% (but I think it should be OK for everybody by the end of this week)

 

@Dawid : happy to hear that ! Thanks for this feedback

About release note the main changes are :

  • Various bug fixes, improvement of OTAs, reduction of discovery time of devices, ...
  • Dimmer switches in HomeKit
  • Integration of Cable Outlet in HomeKit + added to Smart Notifications in pilot wire mode
  • Fix of Smart Notifications behaviour
  • Dimmable ZigBee lights support
  • Support every currency in electrical contract (Electrical Cabinet solution)
  • Support Dry Contact DIN Module (Electrical Cabinet solution)

Have a good day,

Leslie - Community Manager

Thanks for info, but some clarification would be appreciated: what means "dimmable ZigBee lights support"?  Any 3rd party devices can be supported ?

BTW, do you expect that controlling % of opening of shutters and exposing wireless switches to Homekit still should be still released this year (as discussed many times before)?

DW

 

Hi Leslie,

I've answered myself 🙂

So, yes, I can add bulbs like Philips Hue Zigbee 3.0 or probably other ones to Legrand Gateway and it works 🙂

  • I switch, dim, change colour/temperature via H+C app 🙂
  • It's exposed to Homekit and it's sync with H+C: app 🙂
  • I can even control (switch/dim) it by wireless switch 🙂

But I found some bugs/limitations:

  • Event I can even control (switch/dim) it by wireless switch, any changes are not sync with H+C or Homekit. So I can switch off lights but native app or Homekit doesn't see any changes.  It's either bug or limitations 🙁
  • It's not very stable 🙁
  • Of course, in native Philips Hue app I can do a looooot more, but it's quite understandable.

But I think it's opening new possibilities for some contexts/scenarios and it's move in right direction.

Thx

DW

Hi again Dawid,

According to the roadmap and latest tests, opening shutters in % via HK is still planned for the end of the year

Concerning this point : Event I can even control (switch/dim) it by wireless switch, any changes are not sync with H+C or Homekit. So I can switch off lights but native app or Homekit doesn't see any changes.  It's either bug or limitations <= normally, states changes in H+C or HK after a manual push should work with a switch at v46 firmware version minimum. Please verify your firmware version. If it's OK for it, please send me via the contact form the serial number of the switch + the email address of your Home + Control end-user account. I'll then ask for an investigation

When you say "it's not very stable" <= which problem did you encounter ?

 

Have a good day,

Leslie - Community Manager

Hi Leslie, finally got the update and the dimmers are working well now with HomeKit. A question about dimming though, and I wonder if anyone else on this thread may have feedback on this - i have noticed that when at 1% dim level, the Smart Dimmer from Legrand does not dim as much as other no name dimmers. Is there any way to adjust this or does anyone have any ideas/suggestions to get it to dim lower when on the lowest dim setting?

thankyou

Simon

<p style="box-sizing: inherit; margin: 0px 0px 1rem; padding: 0px; line-height: 1.6; text-rendering: optimizelegibility; color: #575757; font-family: 'Segoe UI', 'Noto Sans', sans-serif;">Good news : the issue is found and will be fixed in the next release of the gateway firmware (v.206)</p>
 

Viewing 13 posts - 16 through 28 (of 28 total)

You must be logged in to reply to this topic.

Information

message27 replies
people6 participants