Forum

Browse topics, discover Works With Legrand community!

Smarther API: Gateway offline

Hello,

Smarther API is answering "statusCode": "404","message": "Gateway Offline"

This morning my client application (openhab binding) sent calls every 5 seconds since the gateway was unreacheable, and it is also possible that the 500 calls limit has been exceeded.

Are there any server side issues with smarther API?

In case the API calls limit has been exceeded, the answer is still "404: gateway offline" or is there a specific answer?

 

Hello AZ,

Do you still have this problem ? We don't find any issue on our side with the API

Here is the 404 error :  "404": {
"description": "Resource not found/Gateway offline: something is probably wrong in your request URL or your thermostat is temporary disconnected from the network."

If it's now working, it could have been a little delay issue on our side (but nothing appears in logs) or a temporary issue with your internet connection

Have a good day,

Leslie - Community Manager

hello, everything is working as expected.

i misconfigured API polling frequency and consequently exceeded the limit set at 500/day, as reported in the analytic page under 'my subscriptions'.

API server apparently answers with 404 when the limit gets exceeded.

Hello,

i got "500: Internal server error" today, after 6 days without any issues.

 

nevermind, i just got the email regarding planned maintenance for today

<div style="display: none;"></div>
Hi, we still get 500 Internal Server Error, please check issue.

Hi Onofalt,

I don't see any issue on my side. Can you please give me more info about your problem ?

Have a good day,

Leslie - Community Manager

Hi, I started getting "404: Gateway Offline" approx 14 hours ago. API has worked well for last few weeks.

I'm querying from MS Azure. Weirdly enough, both ping and traceroute to api.developer.legrand.com completely fail.

Hello,

It seems to be OK on my side. Does it still not working ?

Have a good day,

Leslie - Community Manager

It automagically recovered ten minutes ago.

 

2020-11-04 07:52:02.993343, HEATING, AUTOMATIC, INACTIVE, 18.2, 76.7
2020-11-04 07:56:03.711713, HEATING, AUTOMATIC, INACTIVE, 18.2, 76.7
2020-11-05 09:44:02.422293, HEATING, AUTOMATIC, INACTIVE, 15.9, 83.9
2020-11-05 09:48:02.907534, HEATING, AUTOMATIC, INACTIVE, 16.1, 83.9

HEllo i'm having a lot of <span style="color: #575757; font-family: 'Segoe UI', 'Noto Sans', sans-serif;">"statusCode": "404","message": "Gateway Offline" from smarther api in my application.</span>

I'm having troubles with Thermostat app too. My internet connection is OK.

Can you help me?

Hello Guiseppe,

We had a firmware update yesterday, maybe it disconnected your gateway while making the update. Do you still have the issues ? On my side the API correctly answers

Have a good day,

Leslie - Community Manager

Hello Leslie,

I'm still having a lot of troubles. My app is still having "404 - <span style="color: #575757; font-family: 'Segoe UI', 'Noto Sans', sans-serif;">Gateway Offline" or "408 - Request timeout" error. Even Thermostat app can't connect to my thermostats.  My wifi and my internet connection are working.</span>

 

Can you help me, please?

I discussed with the teams, it seems that indeed there is a problem with messages sent to the Thermostat application, causing indirectly issues with the API. They are working to fix it

Have a good day,

Leslie - Community Manager

Hi Leslie,

thanks for the update.

I'll be waiiting for te fix.

'Nice day.

Viewing 15 posts - 1 through 15 (of 24 total)

You must be logged in to reply to this topic.

Information

message23 replies
people6 participants