Forum

Browse topics, discover Works With Legrand community!

Home + Control : Get user plant empty

Hello,

I've looked for any suggestion for my problem but nothing found to resolve it.

 

Explanation of my problem :

I have a user + password to connect to my Home + control application. All is Ok, and I can manage my Bubendorff devices with application.

I have created a partner application account for Alexa. It works fine too (Devices and scenes voice controls Ok).

I have created a developer account and subscribed to starter kit. When I try to send a "get users plants" request by clicking on "try it" button, I receive a http 200, but json is : "plants": [] (empty).

In field "OAuth Server for Try it Eliot API", I enter my user and password used to connect to home + control Application. After this a message like "Access token expires on: 12/23/2020 5:43 PM" appears to the right of this field. Before click "Send" Button, I've checked that "Ocp-Apim-Subscription-Key" and "Subscription key" contain my primary key, and "Authorization" contains "Bearer xxxxxxxx".

Could you help me to understand why response is empty please ?

 

Thanks

 

i attach here a picture about my response. i haven't recive PLANT ID

Images:
You must be logged in to view attached files.

Beste Leslie,

Ik kom er nog steeds niet uit met het halen van plantids via home-control. Als ik ze opvraag, is de verbinding succesvol, alleen iedere keer krijg ik een lege plant object te zien. Ik volg alle stappen van de voorgaande reacties.

Ik zie dat veel componenten zijn deprecated binnen de Legrand account, waaronder de home-control.

Is het nu de bedoeling dat ik de plantids ga opvragen via netatmo? Werkt de home-control überhaupt niet meer?

Met vriendelijke groet,

Jon

Hello Jon,

Please write in English, otherwise it will be complicated for me to answer correctly (thanks Google trad ;))

Concerning the deprecation of Home + Control API on Works with Legrand : we will delete it at the end of 2023. Meanwhile, the API still continues to work as normal. I strongly advise starting using now Netatmo's Home + Control API

If you want to use the H+C API from Works with Legrand (for example to use a third-party application which is not yet migrated to Netatmo's infrastructure) : in main cases when you retrieve a 200 OK response but an empty array, it's an authentication problem

First, assure that you created an application (which is in "Validated" status) and a subscription to the Starter Kit via your Works with Legrand developer account

Then, in the Try-It tool go to the GET user's plant method (https://portal.developer.legrand.com/docs/services/59e9ad7f8bda9e0b3caea28c/operations/getusersplants/console) : when you are connected to your developer account, the OCP-APIM-Subscription-Key is already filled-in

Then in "Oauth server for Eliot Try It API choose "Authorization code". A pop-up will open where you need to use the credentials of your end-user account (the one you use in Home + Control, not the developer one)

You should then access your plant_id value. If it still doesn't work, please send me via the contact form the email address of your Home + Control end-user account

Have a good day,

Leslie - Community Manager

Sorry man, but I still understand... I put into the authorization code the same account that I have, like ad end-user, but still, the API gives me a result 200 OK with plantsID: []. what I do?! I can't use this situation.

Hello Amedeo,

Could you please try the following :
  • go in Home + Control application > menu > My account > Third-party applications
  • at the bottom, you have a link "I can't link a third-party application". Click on it and follow the procedure
  • finally, re-try to use the Try-It function of the GET user's plant method
It should link your Netatmo end-user account to Eliot system
 
Hoping it will resolve your issue,
Have a good day,
Leslie - Community Manager

Hello, i try it your suggest, but nothing. i see that in home+controll, compare a number of allowed app, but the response is []. nothing change...

Amedeo,

I remember we already talked together about this at the end of March. At this time you were talking about Smarther2, which is a device linked to Netatmo's infrastructure and not Eliot (Works with Legrand). I still see in the end-user account you gave me that you only have Smarther2 devices

Are you talking about Home + Control devices, Smarther2, or something else ?

Have a good day,

Leslie - Community Manager

Yes you remember right. i have 2 of x8002. But i don't say nothing news about the implementation on Openhab. and I understand John have the same problem. Nobody know to resolve this annoing problem??

Amedeo,

Jon tries to have access to his devices from the Home + Control solution by using the dedicated API for it on Works with Legrand. I discussed with him via e-mail, and I think his empty plant problem is solved

In your case, you try to access via our API a product (Smarther with Netatmo) which is not in our infrastructure, so we don't provide an API for it

I sent you an email with a reminder of our last discussion

Have a good day,

Leslie - Community Manager

Viewing 9 posts - 16 through 24 (of 24 total)

You must be logged in to reply to this topic.

Information

message23 replies
people5 participants