Forum

Browse topics, discover Works With Legrand community!

Wireless switches not updating

I have some wireless switches, some double wireless switches, and some wired switches.

The double wireless and the wired are updated, however, the wireless switches don't update their firmware.

So some of the when pressing the button toggle, and some turn off or on.

It is a mess.

How can I to force update the wireless switches?

Hello CJ,

Do you also have this issue on wireless switch ? If yes, please tell me the firmware version of the device and the one from your gateway

JD, fingers crossed 😉

Have a good day,

Leslie - Community Manager

Hi, I have the problem only on wireless switch.

My gateway has versión firmware 124

My wireless switches  have version firmware 25.

Thanks

CJ,

Indeed, your wireless switch is not up do date. It's a known bug on our side concerning firmware version lower than 42 on these switches

I invite you to wait for a gateway firmware update to version 149 which should fix it. We started to launch it last week, and please note it could take up to 2 weeks for a worldwide update

Meanwhile, you can also try the 10 pushes method I explained in my previous post (but not sure it will work)

Have a good day,

Leslie - Community Manager

Nothing. After upgrading to 149 I've been trying to upgrade the switch to the latest version with no luck yet...

Any solutions?

I too concur that upgrading to firmware 149 does not solve this issue. However i noticed upgrades to switches with newer firmware. In particular, double wireless switches with firmware 14 were upgraded to 17. Those with 3 or 6 stayed with old firmware.

Please, at least, until you fix it, give us the ability to configure the toggle option.

It is really a painful to have apparently same switches with different behaviour around the house.

Hi JD & Fotis,

Here is a translation from the feedback I had from the Product Manager :

Unfortunately, the gateway update to v.142 made possible to set up a reliable process, but it's really fully efficient only for wireless switches at least at v.42. For former versions, the only solution is to do the 10 wake up process as many times as necessary to obtain the update

Also, we noticed during tests that if we do a reset on a wireless control which is not up to date, and then we add it again in the Zigbee network : the update seems to work faster. But this is empirical, and has not been confirmed by the developers

I understand that the answer is quite disappointing and the proposed solution painful. Unfortunately, we apparently can't do much more on our side to force this update

Have a good day,

Leslie - Community Manager

I still insist in my previous message.

Please, at least, until you fix it, give us the ability to configure the toggle option. Even though it should always be an option to configure, as I bought them working in a different way that I prefer.

It is really a painful to have apparently same switches with different behaviour around the house.

JD,

It's not planned to bring this via a configurable option in Home + Control. The goal is to bring an unified and unique behaviour with all kind of switches (of course, when firmware update works ...)

But I forwarded your message and your issue to relevant contacts working on the project

Have a good day,

Leslie - Community Manager

I'm a beed fed up with this.

I've been spending many hours this evening.

I've tried the 10 times, after a couple of hours, still nothing.

Then, I've remove it, re-added back, waited, done the 10-wake-ups things again.

And 3 hours later, still, nothing.

 

And this is just for one. I have about 15 of these around the house. This can't be the solution after spending quite a lot of many in a "allegedly" good quality device.

Viewing 10 posts - 16 through 25 (of 25 total)

You must be logged in to reply to this topic.

Information

watch_later 1 week, 2 days ago
message24 replies
people5 participants