Forum

Browse topics, discover Works With Legrand community!

Wireless switches not updating

I have some wireless switches, some double wireless switches, and some wired switches.

The double wireless and the wired are updated, however, the wireless switches don't update their firmware.

So some of the when pressing the button toggle, and some turn off or on.

It is a mess.

How can I to force update the wireless switches?

Hello CJ,

Do you also have this issue on wireless switch ? If yes, please tell me the firmware version of the device and the one from your gateway

JD, fingers crossed 😉

Have a good day,

Leslie - Community Manager

Hi, I have the problem only on wireless switch.

My gateway has versión firmware 124

My wireless switches  have version firmware 25.

Thanks

CJ,

Indeed, your wireless switch is not up do date. It's a known bug on our side concerning firmware version lower than 42 on these switches

I invite you to wait for a gateway firmware update to version 149 which should fix it. We started to launch it last week, and please note it could take up to 2 weeks for a worldwide update

Meanwhile, you can also try the 10 pushes method I explained in my previous post (but not sure it will work)

Have a good day,

Leslie - Community Manager

Nothing. After upgrading to 149 I've been trying to upgrade the switch to the latest version with no luck yet...

Any solutions?

I too concur that upgrading to firmware 149 does not solve this issue. However i noticed upgrades to switches with newer firmware. In particular, double wireless switches with firmware 14 were upgraded to 17. Those with 3 or 6 stayed with old firmware.

Please, at least, until you fix it, give us the ability to configure the toggle option.

It is really a painful to have apparently same switches with different behaviour around the house.

Hi JD & Fotis,

Here is a translation from the feedback I had from the Product Manager :

Unfortunately, the gateway update to v.142 made possible to set up a reliable process, but it's really fully efficient only for wireless switches at least at v.42. For former versions, the only solution is to do the 10 wake up process as many times as necessary to obtain the update

Also, we noticed during tests that if we do a reset on a wireless control which is not up to date, and then we add it again in the Zigbee network : the update seems to work faster. But this is empirical, and has not been confirmed by the developers

I understand that the answer is quite disappointing and the proposed solution painful. Unfortunately, we apparently can't do much more on our side to force this update

Have a good day,

Leslie - Community Manager

I still insist in my previous message.

Please, at least, until you fix it, give us the ability to configure the toggle option. Even though it should always be an option to configure, as I bought them working in a different way that I prefer.

It is really a painful to have apparently same switches with different behaviour around the house.

JD,

It's not planned to bring this via a configurable option in Home + Control. The goal is to bring an unified and unique behaviour with all kind of switches (of course, when firmware update works ...)

But I forwarded your message and your issue to relevant contacts working on the project

Have a good day,

Leslie - Community Manager

I'm a beed fed up with this.

I've been spending many hours this evening.

I've tried the 10 times, after a couple of hours, still nothing.

Then, I've remove it, re-added back, waited, done the 10-wake-ups things again.

And 3 hours later, still, nothing.

 

And this is just for one. I have about 15 of these around the house. This can't be the solution after spending quite a lot of many in a "allegedly" good quality device.

Any news in this topic? My gateway has still version firmware 124.

Hello C J,

We stopped the deployment of v149 following the detection of a minor issue. We temporary fixed it in a v150 which is currently deployed (10% of users had it for now) and it will be definitively fixed in a v151 that we will start to deploy this week

Better is still to wait to get v150 or 151 via OTA. Meanwhile, you can send me the e-mail of your user account you use on Home + Control application (via contact form), and I'll check in logs if I see a blocking issue

Have a good day,

Leslie - Community Manager

Hi, I am still in version 25. And the gateway in v151

Any news update?

Thanks

I too confirm that all issues you describe are intact and I believe that they have no interest in providing a solution. I fail to understand why it is technically impossible to add a button and manually update the firmware of the switches or even more peculiar, why it's not feasible to control the on/off behavior of the switches.

 

If indeed it's not technically possible, then I fear we invested in a poorly designed product.

 

Hi,

I have similar problem. I have 3 single wireless switches (Legrand ref. No 067723). They all have different firmware version: v42, v50 and v30. My hub firmware version is v153.

I have already tried several times the "wakeup procedure" with 10 pushes with 10 seconds pause between the pushes. It didn't work...

How can I force all my wireless switches to update to the most recent version? I'm especially interested in updating the one with v30.

BTW, where can I find the list of the most recent firmware versions?

Best regards, Sergey.

 

Viewing 15 posts - 16 through 30 (of 35 total)

You must be logged in to reply to this topic.

Information

watch_later 4 weeks ago
message34 replies
people6 participants