Forum

Browse topics, discover Works With Legrand community!

Legrand wireless switch on homekit without wired switch

Hello.

Is there any reason why wireless switch cannot be used autonomously and exposed to homekit without using a wired switch? That way the switch could be used to control other homekit accessories or scenes eg.. Hue lights. This is possible using a custom zigbee hub, so why not with the original one?

I do not have a firmware update yet

I can see my gateway is on v.250 now. Sometime tonight or tomorrow I will be able to check if wireless switches can be added within HomeKit .

Mine has 211 all the time. I hope it will update.

I just did some limited testing and here are the results.

 

important to know that I’m in the USA, and we have two product lines a available; Radiant with Netatmo and Adorne with Netatmo. Adorne is very similar to Arteor.

In each product line I tested a wireless switch, wireless dimmer, and wireless home/away switch. The only switch that appeared in HomeKit was the Radiant wireless switch, part # WNRL23.

None of the adorne with Netatmo devices would appear in HomeKit, and I did not test any other Radiant with Netatmo scene switches after seeing the home/away did not work.

within HomeKit, the WNRL23 appears as a wireless switch. When you go into settings, you can select options for “Button push 1” and “Button push 2.”

1 being up/on

2 being down/off

 

You can program those two selections to activate and device or scene state within HomeKit. It’s a really cool feature.

 

However there is one issue I can’t work around. When you add a wireless devices within the Legrand Home + Control app, you must bind it to a wired device. So I bound mine to my pool light. Within HomeKit I set the switch to control a Philips Hue lamp, however it still controls my pool light simultaneously, and I cannot find a solution within the Home + Control app to disassociate the wireless device from the wired device.

That issue will have to be resolved before this function can be used for HomeKit control.

 

I’m very happy Legrand/Netatmo has come this far, and i very much hope we will see adorne devices supported soon. My entire home has adorne devices, and I was very much looking forward to this feature as a way to control Philips Hue lamps.

Can I force a gateway update?

Hmm.... I wonder if Legrand Adorne doesn't work then Legrand Celiane/Valena Life/Valena Allure (available in Europe) will behave similar to Radiant or Adorne series?

I think we are seeing the result of HomeKit limitations.

 

I have been reviewing several demonstration videos of other single-button HomeKit devices, and it appears the only setup options within HomeKit are 'Single Press', 'Double Press', and 'Long Press'.

Double-press and Long-press are not intuitive ways to interact with a push-button light switch.

HomeKit doesn't seem to have a reverse-state function that would allow intuitive use of adorne/valena/Celiane type devices i.e. single-push on, followed by single-push off state.

 

The adorne switch does have two distinct off/on push buttons underneath, but its not readily apparent to the user where to press to activate each button. Off is center-left. On is upper-left.

 

What I would like to see going forward is the addition of adorne scene switches to have this function, as they do have apparent off/on up/down targets. This would allow use of the scene switches to include non-Legrand devices within the scene, and program directly within HomeKit.

 

Lastly, with the Radiant switch that does work, I still haven't found a way to disassociate the wireless switch from a wired Netatmo device. For now in my testing I have it paired to a plug-in outlet device. Every time you press a button to activate something in HomeKit, it is simultaneously switching the WNRP plug in outlet.

 

Again, Leslie please say thank you to the engineers for getting it this far. I'm looking forward to seeing what other developments they can come up with.

Brant,  you can use Shortcuts to mimic normal on/off switch behaviours.  (https://homekitnews.com/2019/12/24/create-an-on-off-toggle-switch-with-home-and-shortcuts/) .

I used Aquara wireless switches this way and it perfectly works as on/off toggle switch with single-press and some extra scenes with double-press and long press.

So, I guess that it's also possible with Legrand.

Good to know, thanks! I did see within the HomeKit settings for the WNRL23 wireless switch an option to “convert to shortcut.”

 

I am hopeful Legrand is working on adding the adorne devices.

The only devices I don’t have to test are the mechanical switch module and relay module, as they are not sold in the US, but I am working with my Legrand rep on acquiring these. I am curious if the mechanical switch module shows up in HomeKit. The Bticino part # is 3577C.

Hello all,

Just updated to gateway firmware v 250, I see most of my wireless switches on Homekit (Homekit hub not installed yet so I can't use them, but it should not be an issue) - as long as the switches are firmware v 54 or v 55.

However some difficulties:

  • I'm unable to update a Celiane/Netatmo Wake-up/Sleep switch to v54/55. It's stuck on v16. My Home/away switch is on v54, so does a newer firmware exist fo wake-up/sleep switch? ref 064886A
  • I have one wireless switch ref 064893A which was rev 42, Home+Control app was always telling me that there was a name inconsistency between homekit and Home+Control - there wasn't. I was also unable to rename the switch, I only could either move or delete the switch.
    After updating it to v55, still same issue, so I deleted it, and added it again. Now I cannot pair it to any light controlled by Legrand gateway, the "configuration" screen doesn't appear (screenshot attached). Deleted it and re-paired several times, same issue. Another switch which was updated from v18 to v55 does not have this problem.

 

Is this normal behaviour for firmware v55 for ZLE18? I can pair the switch with my light within Homekit once I have a Homekit hub, but I'd prefer if it stayed within the Legrand Zigbee network.

Images:
You must be logged in to view attached files.

Frederic, how are you forcing the update? I can't manage to find an option in the Control app to force the update. I see some of my switches are still in firmware revision 47 and my gateway still on rev 211.

 

Thanks!

Hello,

@Frederic : we launched the v59 2 weeks ago for 064886 (I'm still on v54 on my test installation). I invite you to try the manual process below, and if it still doesn't update you should contact the Customer Support of your country

Your screenshot is a little surprising as it's lacking configuration, but also the serial number as if it wasn't connected or recognized by the installation. I also advise you to check with the Customer Support for it

 

@Javier : our update process is automatic and progressive. We don't have any option for it in the app. We have a process to "force" an update for a switch but it's not an exact science and doesn't work 100% of the time. Concerning the Gateway, you just have to wait and it should arrive soon. Of course, your devices must be linked to the Legrand/Bticino gateway in order to benefit from the updates

  • If possible, best is to first remove and put back the battery (if wireless switch)
  • Push the switch button and wait 10 seconds
  • Redo it 10 times and wait 10 seconds between each push
  • Normally, in the next 30 minutes, the firmware should be up to date

 

Have a good day,

Leslie - Community Manager

Hi Leslie,

I removed the serial number for privacy, it is there 🙂 I just did it nicely with the same colour. I'll try to contact customer support (or re-reset again).

Mateusz Twardowski 

Theres is a kind "brutal" way to force gateway upgrade, just you have to reset gateway (hard) and configure once again. When gateway is in a process of connecting to Wi-Fi and setting new home, it checks recent updates and then eventually start updating.

Of course it's far from comfortable if you'll pushed to set all your devices, automations and so on. In my house I have 2 gateways (Valena Life) and one is connected to only 2 devices, so I tried above approach. And it really works 🙂

Moreover, for a sake of testing I was able to add some switches and they appear in my Homekit  and it's also seem to be working as intended (though I had to switch on/off my HomePod several times).

Now, I'm waiting for OTA upgrade of my main gateway.

Now I see that only my Radiant on/off switch is on firmware v55; none of my other devices have updated firmware yet, so maybe that is the reason I do not see them in HomeKit.

Does anyone have a Bticino 3577c wireless switch module to test? They are not sold in the US, but my Legrand rep was able to place an order for me. I don’t know how long it will take for them to ship to me from Italy. I ordered some of the motion sensors and wireless relays also.

Viewing 15 posts - 31 through 45 (of 59 total)

You must be logged in to reply to this topic.

Information

watch_later 1 week, 2 days ago
message58 replies
people12 participants